Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-23620

ioslib fails to choose a watch simulator under Xcode 8.0 Beta

    Details

    • Story Points:
      3
    • Sprint:
      2016 Sprint 15 Tooling

      Description

      Trying to build app and run it on the simulator errors out with watch app on Xcode 8.0 beta

      Steps to reproduce

      1. appc new --classic
      2. Enter project root
      3. appc new -t applewatch
      4. appc run -p ios -I 10.0 --launch-watch-app -l trace

      Expected result

      App launches successfully with both iOS and watch simulators

      Actual result

      Build fails with the following error:

      [INFO]  Launching iOS Simulator
      [TRACE] [ioslib] Found watchOS 3.0 app: com.appcelerator.timob23614.watchkitapp
      [ERROR] Specified Watch Simulator "B3649832-4484-4A43-8468-BC7D8931F4D0" is not compatible with iOS Simulator "AD4CB766-B439-4E20-B441-8EA281CC3658".
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jvennemann Jan Vennemann
                Reporter:
                jvennemann Jan Vennemann
                Reviewer:
                Chris Barber
                Tester:
                Harry Bryant
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-9904
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration