Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-23479

Windows: Local webview does not show any images, or opens other files.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 5.3.0
    • Fix Version/s: Release 6.0.0
    • Component/s: Windows
    • Labels:
      None
    • Story Points:
      8
    • Sprint:
      2016 Sprint 13 SDK

      Description

      Hello, I have a local webpage which I want to open in webview. This works fine, But, I have an image, inside my webpage, which does not show when the webview opens.

      I am putting my html and image file in assets directory, which is not working. I even tried to put the files in lib directory, which also does not work.

      I also tried with hyperlink inside my webpage, which will open another local webpage. I can see the hyperlink in webview but clicking on it does not open my webpage.

      I am testing for both alloy and classic project. I am using SDK 5.2.2.GA and 5.3.0.GA.

      var webview = Titanium.UI.createWebView({url:'logging.html});
          var window = Titanium.UI.createWindow();
          window.add(webview);
          window.open({modal:true});
      

      <Alloy>
          <Window id="win" modal="true">
              <WebView id="webview" url="logging.html" />
          </Window>
      </Alloy>
      

      I have tested in android without any problem. Thanks.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kiguchi Kota Iguchi
                Reporter:
                sdarda Sharif AbuDarda
                Reviewer:
                Christopher Williams
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-9801
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code