Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-23192

Windows: Prompt for selecting wp-sdk option contains unsupported 8.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 5.3.0
    • Fix Version/s: Release 5.3.0
    • Component/s: Windows
    • Labels:
    • Environment:

      Windows 10 Pro
      Visual Studio 2015 Community Update 2
      Appc Core: 5.3.0-12
      Appc NPM: 4.2.5-1
      Ti SDK: 5.3.0.v20160411153728

    • Story Points:
      3
    • Sprint:
      2016 Sprint 08 SDK

      Description

      Description

      If an invalid value is passed in for --wp-sdk then the CLI will prompt the user to select an SDK, the prompt is below and 8.0 which is unsupported

      Please select a valid wp-sdk value:
       1)  8.0
       2)  8.1
       3)  10.0
      

      Note

      If 8.0 is selected then the build will fail with

      [INFO]  -- The C compiler identification is unknown
      [INFO]  -- The CXX compiler identification is unknown
      [WARN]  CMake Error at CMakeLists.txt:17 (project):
        No CMAKE_C_COMPILER could be found.
      [WARN]  CMake Error at CMakeLists.txt:17 (project):
        No CMAKE_CXX_COMPILER could be found.
      [INFO]  -- Configuring incomplete, errors occurred!
      See also "C:/Users/Ewan/.titanium/vsbuild/prodclassic/store.x86/CMakeFiles/CMakeOutput.log".
      See also "C:/Users/Ewan/.titanium/vsbuild/prodclassic/store.x86/CMakeFiles/CMakeError.log".
      

      or

      2016-04-12T04:09:16.746Z | ERROR  | An uncaught exception was thrown!
      No Windows Phone emulators found
      2016-04-12T04:09:16.749Z | ERROR  | No Windows Phone emulators found
      

      depending on the chosen target

      Steps to reproduce
      1. Run appc run -p windows -T ws-local --wp-sdk 10
      Actual result

      You will be prompted to choose a valid SDK, with 8.0 in as a possible value which is unsupported

      Expected result

      Unsupported versions should not be in the prompt

        Attachments

          Activity

            People

            • Assignee:
              gmathews Gary Mathews
              Reporter:
              eharris Ewan Harris
            • Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • It looks like Backbone Issue Sync is not enabled for your project.

                  Git Source Code