Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-20571

Windows: Improve the detection of the Windows SDK used to build a project

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.3.0
    • Component/s: Windows
    • Labels:
    • Environment:

      Windows 10 Pro
      Appc NPM: 4.2.4-2
      Appc Core: 5.2.1-13
      Ti SDK: 5.3.0.v20160311122340
      Lumai 930 10.0.10586.164

    • Story Points:
      13
    • Sprint:
      2016 Sprint 08 SDK

      Description

      Description

      Currently when building a project the default SDK used will be 8.1, this means that if a user simply runs appc run -p windows -T wp-emulator then they will only be shown Windows 8.1 emulators, in order to be shown Windows 10 mobile emulators a user must run appc run -p windows -T wp-emulator -S 10.0. The CLI should show a user all possible emulators and then determine which Windows SDK is needed to build based off the choice made by the user.

      Steps to reproduce

      1. Run appc run -p windows -T wp-emulator

      Actual result

      You will be prompted to select from only 8.1 emulators

      Expected reult

      You should be prompted to select from all possible emulators

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gmathews Gary Mathews
                Reporter:
                eharris Ewan Harris
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration