Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-20393

iOS: Launch Image Set leaves out required sizes if no (>=8.0) minimum iOS version is set

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.2.0
    • Fix Version/s: Release 5.2.0
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      SDK 5.2.0.v20160211193617

    • Story Points:
      2
    • Sprint:
      2016 Sprint 03 Tooling

      Description

      When I build an app without setting a minimum iOS version it defaults to 7.1. In that case, I noticed launch images for iPhone 6+ were missing.

      This is caused by the following commit:
      https://github.com/appcelerator/titanium_mobile/commit/105a1fdf72e8f349f71ba10c08c738d9160910ec#diff-f430483233aa01af5b10df8390f9635dR4931

      Which is related to the storyboard ticket TIMOB-19694

      I don't get the logic for this validation of minIosVer. If that is the minimum iOS version the launch image is supported on, then surely it should be removed when you'd set a max iOS version (which I don't even think you can't). If you build to support iOS 7+ then of course the launch images for 8+ should be included, right?

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              fokkezb Fokke Zandbergen
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-20950
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code