Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-20143

Windows: Titanium.UI.WebView don't load local html page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.1
    • Fix Version/s: Release 5.3.0
    • Component/s: Windows
    • Environment:

      OS: Windows 8.1 Pro
      Visual Studio: 2013 Update 4
      Appcelerator Studio: 4.4.0
      Titanium SDK: 5.1.1.GA

    • Story Points:
      5
    • Sprint:
      2015 Sprint 26 SDK

      Description

      I cannot load local html page (located in Resources directory)

      This code works on Android and iOS but on Windows 8.1 give "Unknow error"

      var htmlPage = "/help.html";
      $.webview.url = htmlPage;

      This workaround code on Windows 8.1 don't give any error but don't load the page (blank screen)

      var htmlPage = Ti.Filesystem.resourcesDirectory + Ti.Filesystem.separator + "help.html";
      $.webview.url = htmlPage;

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kiguchi Kota Iguchi (Inactive)
                Reporter:
                luk3luk3 Luca Sartori
                Reviewer:
                Christopher Williams
                Tester:
                Harry Bryant
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-20786
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code