Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-20014

iOS: Incremental builds fail to update with "--skip-js-minify"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.0
    • Fix Version/s: Release 5.1.0
    • Component/s: Tooling
    • Environment:
    • Story Points:
      3
    • Sprint:
      2015 Sprint 23 Tooling

      Description

      Description:

      This is a REGRESSION from 5.0.2.GA

      Incremental builds fail to update changes when targeted to iOS devices. However, this only occurs when the project has platform services ENABLED, and incremental builds reflect changes correctly with platform services disabled. It is worth noting that the incremental build times are considerably shorter than the initial build for both instances ( 4 - 7 seconds ). This issue is verified as affecting both iOS8 & 9 devices, but does not affect simulator builds.

      Steps to reproduce:

      1. Create a classic project with services enabled
      2. Build project to device ( iOS8, iOS9 )
      3. Make a change to app.js file
      4. Build project to device again.

      Result:

      Changes made to app.js will not be reflected in the new build with platform services enabled.

      Expected Result:

      Changes made to app.js should be reflected in the new build with platform services enabled.

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              htbryant Harry Bryant
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-20697
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration