Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19884

iOS: Debug crash when setting breakpoint in alloy model response

    Details

    • Story Points:
      5
    • Sprint:
      2015 Sprint 14 Studio, 2015 Sprint 25 SDK

      Description

      When setting a titanium studio breakpoint in an alloy model response from a sync adapter that fetches remote content, titanium 3.5.0 crashes in iOS.

      Here is an example alloy project that fetches remote content using a custom alloy model adapter:
      https://github.com/jkotchoff/alloytest

      When run in 'debug mode' in Titanium Studio, setting a breakpoint in the alloy model response will crash the app with SDK 3.5.0 and iOS
      ie.
      https://github.com/jkotchoff/alloytest/blob/master/app/controllers/index.js#L7

      A debug point here works fine in SDK 3.4.1 on iOS and it works fine in Android (SDK 3.4.1 or 3.5.0).

      This makes debugging titanium apps that render content from a remote server impossible in 3.5.0 on iOS.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cng Chee Kiat Ng (Inactive)
                Reporter:
                cornflakesuperstar Jason Kotchoff
                Reviewer:
                Pedro Enrique (Inactive)
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-20610
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code