Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19750

TiSDK 4.1 Example App doesn't run with Visual Studio 2015 Community on Windows 10...

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Windows

      Description

      I'm trying to get the Ti SDK 4.1 Example App and eventually my app built under Windows 10
      I have Appcelerator Studio, build: 4.1.1.201507141126 installed on Windows 10 Pro (released)
      No appcelerator updates were found
      OS Name Microsoft Windows 10 Pro
      Version 10.0.10240 Build 10240
      The Windows, Android and Mobile Web SDKs are installed
      I have Visual Studio 2015 Community version 14.0.23107.0 D14REL installed
      When I run the Windows Phone Developer Power Tools 8.1 I can connect to an emulator
      I have "Debug" selected in the "Run/Debug/Profile/Test/Package" dropdown
      I have tried selecting several of the windows mobile emulators including "Emulator 8.1 1080P 5.5 inch" and "Emulator 10.0.10240.0 720p 5 inch 1 GB" from the target drop down list.
      When I click on the green "Debug" button absolutely nothing happens in the console window even if the emulator is already launched from the Power Tools
      I noticed that node 0.12.2 was installed already so I installed nvmw and node v0.10.13 which is working properly on my Mac. However the problem still persists. I click on the "Debug" button and nothing happens.

      When I run app run -p windows -C "Emulator 8.1 1080P 6 inch" I do get some output. I get an error that says

      CMake error at CMakeLists.txt:15 (project):
      A windows Phone component with CMake requires both the Windows Desktop SDK
      as well as the Windows Phone "8.1" SDK. Please make sure that you have
      both installed.

      Since I have Visual Studio Community 2015 Version 14.0.23107.0 D14REL (release version) installed I believe that the SDKs must be there and Appcelerator Studio just doesn't know where to find them.

      I have the Windows SDK Home: preference set to "C:\Program Files (x86)\Microsoft SDKs" which is what I assume it should be so I'm not sure what to try next.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cwilliams Christopher Williams
                Reporter:
                dspells Henry David Spells III
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-20516
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code