Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19680

iOS: Building aborts during icon set creation without reason

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 5.1.0
    • Fix Version/s: Release 5.1.0
    • Component/s: None
    • Labels:
    • Environment:
    • Story Points:
      1
    • Sprint:
      2015 Sprint 20 Tooling

      Description

      When building a project for iOS (sim, device, or store) the process aborts while creating the icon set. A warning for an icon's alpha channel is shown, but no error or definie reason is given for the build to fail. See below console output:

      [INFO]  Creating app icon set
      [DEBUG] Writing /Users/ewieber/THISTOO/build/iphone/Assets.xcassets/Contents.json
      [DEBUG] Unsupported app icon Resources/iphone/appicon-60.png, skipping
      [WARN]  Skipping Resources/iphone/appicon-60@2x.png because app icons must not have an alpha channel
      TRACE  | titanium exited with exit code 0
        appc:run signal received +31s exit sending to ChildProcess {
        domain: null,
        _events: { close: [Function] },
        _eventsCount: 1,
        _maxListeners: undefined,
        _closesNeeded: 1,
        _closesGot: 1,
        connected: false,
        signalCode: null,
        exitCode: 0,
        killed: false,
        spawnfile: '/usr/local/bin/node',
        _handle: null,
        spawnargs: 
         [ '/usr/local/bin/node',
           '/Users/ewieber/.appcelerator/install/5.0.2/package/bin/appc',
           'run',
           '-p',
           'ios',
           '-T',
           'device',
           '-l',
           'trace' ],
        pid: 3527,
        stdin: null,
        stdout: null,
        stderr: null,
        stdio: [ null, null, null ] }
      

      Steps to reproduce issue
      1. Create a new native alloy project with appc new
      2. Build that project with appc run -p ios

      Actual Results
      The above output is shown and the process quits during icon set creation

      Expected Results
      The build succeeds or a clear reason for a failure is given.

      Notes
      This could also be a bug. If builds fail when there is a 32-but image, then we should not include any in our default projects.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                ewieber Eric Wieber (Inactive)
                Reviewer:
                Chee Kiat Ng (Inactive)
              • Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration