Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19314

Android Map doesn't compile with 4.1.0.GA

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 4.1.0
    • Fix Version/s: Release 4.1.1
    • Component/s: Android
    • Labels:
    • Sprint:
      2015 Sprint 16 SDK

      Description

      Building map module with 4.1.0.GA result in with this error:
      [javac] KrollDict d = ((TiViewProxy) obj).toImage();
      [javac] ^
      [javac] required: KrollDict
      [javac] found: TiBlob
      [javac] Note: Some input files use unchecked or unsafe operations.
      [javac] Note: Recompile with -Xlint:unchecked for details.
      [javac] 1 error
      [javac] 10 warnings

      This is the result of a method signature change in: https://github.com/appcelerator/titanium_mobile/pull/6907

      Reproducible steps:
      1. Build the module with 4.1.0.GA and observe the logs.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                hpham Hieu Pham
                Reporter:
                hpham Hieu Pham
                Reviewer:
                Ashraf Abu (Inactive)
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-20217
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code