Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19185

Liveview: Update liveview to work with Windows Platform

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 4.1.0
    • Fix Version/s: Release 5.2.0
    • Component/s: LiveView, Windows
    • Labels:
    • Environment:

      Windows 8.1
      Appc CLI (NPM): 4.1.0-1
      Appc CLI (Registry): 4.1.0-0
      Ti SDK: 4.1.0.v20150706111546
      Appc Studio: 4.1.0.201507061507

    • Story Points:
      5
    • Sprint:
      2015 Sprint 24 SDK

      Description

      Description

      Currently Liveview does not work when building for Windows Platform, when passing in the --liveview flag it appears that no liveview server is started as there is no logging related to this.

      I believe that this will require liveview to be updated and also the _restart method to be implemented for Ti.App

      Steps to reproduce

      1. From the CLI run appc run -p windows -T wp-emulator --liveview

      Actual result

      Liveview does not appear to start, no logging related to staring the file server occurs, when making changes to files the app is not reloaded

      Expected result

      Liveview should work when using Windows Platform apps

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gmathews Gary Mathews
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Christopher Williams
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code