Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-19152

Windows: App crashes on second launch when encryption is enabled

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 4.1.0
    • Fix Version/s: Release 4.1.0
    • Component/s: Windows
    • Labels:
    • Environment:

      Windows 8.1
      Appc CLI (NPM): 4.1.0-1
      Appc CLI (Registry): 4.1.0-4
      Ti SDK: 4.1.0.v20150702030940

    • Story Points:
      5
    • Sprint:
      2015 Sprint 14 Windows

      Description

      Description

      When building to either device or emulator with encryption enabled the app crashes every time after the first launch.

      Steps to reproduce

      1. Build to a device using appc run -p windows -T wp-device or an emulator using appc run -p windows -T wp-emulator -D production
      2. When the app launches fully quit the app
      3. Reopen the app from the app menu

      Actual result

      The app will crash

      Expected result

      The app should not crash

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gmathews Gary Mathews
                Reporter:
                eharris Ewan Harris
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-20090
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code