Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-18913

Android: VideoPlayer is not playing mp4 videos anymore on Android L/Lollipop/5

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 5.0.0
    • Component/s: Android
    • Labels:
      None
    • Environment:

      Android L (5.1)
      Nexus 7
      Ti SDK 3.5.1

    • Story Points:
      5
    • Sprint:
      2015 Sprint 14 SDK

      Description

      Description:

      Video playback on Android L seems broken with SDK 3.5.1 (and 4.0.0RC2). MP4 files do not show video and audio output.

      How to reproduce:

      Run the attached app.js on a Android L device. Code is taken from http://docs.appcelerator.com/titanium/3.0/#!/api/Titanium.Media.VideoPlayer.

      What should happen:

      Video should be played after the app is deployed.

      What does happen:

      Blank/Black VideoPlayer, no video is played, no sound.
      After several seconds the console shows (both of them!):
      [ERROR] : MediaPlayer: error (1, -2147483648)
      [ERROR] : MediaPlayer: Error (1,-2147483648)
      Nothing more changes.

      Setting autoplay to false and adding a call to .play on the VideoPlayer object creates this log message:
      [WARN] : VideoPlayerProxy: (main) [101,101] Player action ignored; player has not been created.

      Where does it work:

      The same app does work on a Nexus 10 device running Android 4.4.4 (KitKat). It does not work either on other devices running Android 5.0.2 and 5.1. It does work in iOS simulator. It does not work with Ti SDK 4.0.0RC2 on Android 5.1. Several different mp4 files do not work either in the environment described.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                msamah Ashraf Abu (Inactive)
                Reporter:
                AppDev AppDev
                Reviewer:
                Hieu Pham
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-19920
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code