Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-18610

Debugger: Breakpoint not hit in loop of click event

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 3.5.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      Titanium SDK 3.5.1.v20150223154830
      Studio 3.4.2.201502181619
      CLI 3.4.2-alpha

      Description

      Using the attached file in a project, I do not see a breakpoint being hit when inside the loop of the click event (line 31).

      Steps to reproduce issue:
      1. Use the attached app.js to create a new project
      2. Add a breakpoint to line 31 (Ti.API.debug("Hello: " + i)
      3. Debug the project and click on the label: "I am Window 1"
      4. Notice that the breakpoint is not hit

      Expected result:
      The breakpoint is hit on each iteration of the for-loop

        Attachments

          Activity

            People

            • Assignee:
              cng Chee Kiat Ng (Inactive)
              Reporter:
              ewieber Eric Wieber (Inactive)
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-19749
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code