Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-17190

CLI: "ti setup sdk" fails on second time when CLI has invalid SDK configuration.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: Release 3.3.0
    • Fix Version/s: Release 3.3.0
    • Component/s: CLI
    • Labels:
    • Environment:
    • Story Points:
      1
    • Sprint:
      2016 Sprint 19 Tooling

      Description

      ti setup sdk fails on second time when CLI has invalid SDK configuration.

      Steps To Reproduce:

      1. Run ti sdk command and check the current selected SDK version
      2. Rename or delete that SDK folder from your machine
      3. Then run ti setup sdk command
      4. Enter a value to setup default sdk version.
      5. Skip "Path to find and install Titanium SDKs" settings by pressing Enter.
      6. Setup main menu will appear. You press 7 or sdk again.

      Actual Result:

      Error message thrown. Please see the attachment for more info.
      [ERROR] RangeError: Invalid array length

      Expected Result:

      It should display "Titanium SDK Settings" menu.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                kvelummaylum Kajenthiran Velummaylum
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-18875
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration