Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-17152

CLI: Ti info reports minimum Android SDK as API level 10, accurate for Android module building, inaccurate for SDK compile target

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.3.0
    • Fix Version/s: Release 3.3.0
    • Component/s: Android, CLI
    • Environment:

      Titanium SDK: 3.3.0.v20140612101712
      Appcelerator Studio, build: 3.3.0.201406061445
      CLI: 3.3.0-rc

    • Sprint:
      2014 Sprint 12 Tooling

      Description

      Description

      While running ti info command, the CLI reports that my older Android SDKs are not supported. This is accurate, but the minimum supported Android SDK is not. The CLI states "API 10" as the minimum but in reality it's "API 14".

      An additional note is that Android module building requires API 10, so this may require a different course of action if the decision is made to fix the CLI output or remove the API 10 dependency for Android module building.

      Here is an example of the CLI output:

      Android Issues
        !  Android API Android 2.2 (android-8) is too old and is no longer supported by Titanium SDK 3.3.0.
           The minimum supported Android API level by Titanium SDK 3.3.0 is API level 10.
       
        !  Android API Google APIs (Google Inc.:Google APIs:8) is too old and is no longer supported by
           Titanium SDK 3.3.0. The minimum supported Android API level by Titanium SDK 3.3.0 is API level
           10.
      

      Steps to reproduce

      1) Ensure you have Android SDKs installed < API 10
      2) Run "ti info" in terminal

      Result

      Output as shown above

      Expected result

      CLI reports minimum in sync with SDK minimums.

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              emerriman Eric Merriman
              Reviewer:
              Tim Poulsen
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-18846
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code