Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-16996

CLI: Node and NPM versions are displaying incorrectly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 3.3.0
    • Fix Version/s: Release 3.3.0
    • Component/s: CLI
    • Environment:

      Mac OSX 10.9.3
      Appcelerator Studio, build: 3.3.0.201405161313
      Titanium SDK, build: 3.3.0.v20140519164911
      Titanium CLI, build: 3.3.0-alpha3
      Alloy: 1.4.0-alpha
      Node: v0.10.28

    • Sprint:
      2014 Sprint 11 Tooling

      Description

      Description

      'ti setup check' displays the latest available version to be 0.10.26, despite the latest version actually being 0.10.28. The issue is similar with NPM, the displayed latest is 1.4.3, whereas it's actually 1.4.9.

      Steps To Reproduce

      1. Install the latest node.js installer
      2. Run 'ti setup check'

      Expected Result

      Should display you have the latest node and npm available

      Actual Result

      Says we can update to an older version

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              sdowse Samuel Dowse
              Reviewer:
              Tim Poulsen
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-18731
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code