Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-16515

CLI: IOS - check min iOS version setting in Tiapp below iOS 6.0, which should then ignore the setting and default to 6.0

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 3.2.2
    • Component/s: CLI, iOS
    • Environment:

      Description

      When a min iOS version is set in tiapp.xml and the project built for simulator or device, there is no info in the log, explaining the reason of default setting instead of custom settings.
      h.5 To reproduce
      1) Create a project in Studio with an iOS target
      2) Edit the tiapp.xml to include the following and save the changes:
      <ios>
      <min-ios-ver>4.0</min-ios-ver>
      </ios>
      3) Build the project for any version iOS simulator and observe logs
      h.5 Expected result
      The following appears in the log:
      [INFO] Minimum iOS version 4.0 is lower than 6.0: Using 6.0 as minimum
      [INFO] Minimum iOS version: 6.0

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              oromero Olga Romero
              Reviewer:
              Sabil Rahim
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Integration