Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-16462

iOS: Poor animation when opening a window from a tab on a slow simulator / device

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Won't Do
    • Affects Version/s: Release 3.2.1
    • Fix Version/s: None
    • Component/s: iOS

      Description

      When you open a new window from within a tab the open animation sort of animates in a jagged/shocking way. As if the animation is rendered using large blocks with a height of ~100pixels at a time. Even the root window's background color often shows in the bottom half of the screen.

      I managed to capture the effect in a screenshot using the iPad Retina simulator.

      You can reproduce the issue by creating the default Classic/Tabbed application template and opening the window. The effect is most obvious on a retina iPad in landscape.

      This is the call that triggers the open with the default animation.

      self.containingTab.open(Ti.UI.createWindow({
        title: L('newWindow'),
        backgroundColor: 'white'
      }));
      

      The issue has been in Ti SDK for as long as I know. I always thought I was doing something wrong, but I am not... So time to report the issue cause apparently no one else is seeing it...

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              martijnkooij Martijn Kooij
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-18372
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code