Details

      Description

      Affected versions (Titanium SDK for iOS):

      3.2.0.v20131204220843, 3.2.0.v20131102082008,
      any version greater than 3.1.3.GA

      iOS version : 7.x

      Problem: Settings.bundle is not loaded into the settings app.

      Attached is a sample app that demonstrates the issue.

      To reproduce do the following:

      • Reset iOS (iPad or iPhone) simulator
      • Build the sample app using Titanium SDK 3.1.3.GA
        exit the app, go to the settings app, notice that there is a setting for iosbug.
      • Reset iOS (iPad or iPhone) simulator
      • Clean the build
      • Build the sample app using Titanium SDK 3.2.0.v20131204220843
      • Observe there is no iosbug setting in the setting app

      THIS IS THE LATEST NIGHTLY BUILD OF THE TITANIUM SDK.
      I would consider this a critical bug. This feature has always worked before.

      The zip file is 2.2MB because of default iOS graphics.

      I have also included a simulator screenshot of the settings app screen when the titanium app is using 3.1.3.GA and 3.2.0.v20131204220843 the file names denotes which version you are viewing.

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              sophrinix Andrew McElroy
              Reviewer:
              Allen Yeung
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-17987
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code