Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-15740

CLI: Info command displays extra incorrect Xcode info when 3.1.x SDK is selected

    Details

      Description

      When a 3.1.x SDK is selected, the legacy Xcode info prints that it's not supported and the Titanium SDK version is undefined. The problem is this text should not have been rendered at all.

      Expected:

      Xcode
      5.0.2 (build 5A3005) - Xcode default
        Install Location                      = /Applications/Xcode.app/Contents/Developer
        iOS SDKs                              = 7.0
        iOS Simulators                        = 6.1, 7.0
      4.6.3 (build 4H1503)
        Install Location                      = /Applications/Xcode46.app/Contents/Developer
        iOS SDKs                              = 6.1
        iOS Simulators                        = 5.0, 5.1, 6.0, 6.1
      

      Actual:

      Xcode
      5.0.2 (build 5A3005) - Xcode default
        Install Location                      = /Applications/Xcode.app/Contents/Developer
        iOS SDKs                              = 7.0
        iOS Simulators                        = 6.1, 7.0
        Supported by TiSDK undefined          = no
      4.6.3 (build 4H1503)
        Install Location                      = /Applications/Xcode46.app/Contents/Developer
        iOS SDKs                              = 6.1
        iOS Simulators                        = 5.0, 5.1, 6.0, 6.1
        Supported by TiSDK undefined          = no
      

      To reproduce:
      1) Select a 3.1.x SDK: "ti sdk select 3.1.4.GA"
      2) Run "ti info -t ios"
      3) Look at the Xcode info section

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              cbarber Chris Barber
              Reviewer:
              Sabil Rahim
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-17841
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code