Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-15576

iOS: Simulator - Add support for iPad Retina (64-bit)

    Details

      Description

      Details: If you have Xcode 5.0.1, which has iOS 7.0.3, Studio GA (3.1.3.201309132423) and Studio RC (3.1.4.201310152018) cannot launch simulator iPad Retina (64-bit).

      Simulator iPad Retina (64-bit) will simulate the iPad Air and iPad Mini with retina display hardware.

      Steps to reproduce:
      1. Make sure to install Xcode 5.0.1 on your machine
      2. In either Studio GA or Studio RC, create a default Titanium or Alloy app
      3. Right-click on the newly created project
      4. Go to Run As > Run Configurations ...
      5. Find Titanium iOS Simulator and create a new configuration
      6. Specify Device as iPad, Simulator Version as 7.0, and Display Type as Retina & Tall (64-bit); see config.png
      7. Press Apply and press Run

      Actual: Simulator iPad Retina 7.0.3 is launched; see ipad_simu.png and ipad_simu2.png

      Expected: Simulator iPad Retina (64-bit) 7.0.3 should be launched instead; see ipad_simu3.png

      Note: We also noticed Studio not picking up the iOS 7.0.3 SDK: https://jira.appcelerator.org/browse/TIMOB-15575

        Attachments

        1. config.png
          config.png
          86 kB
        2. ipad_simu.png
          ipad_simu.png
          65 kB
        3. ipad_simu2.png
          ipad_simu2.png
          599 kB
        4. ipad_simu3.png
          ipad_simu3.png
          491 kB

          Issue Links

            Activity

              People

              • Assignee:
                srahim Sabil Rahim
                Reporter:
                wluu Wilson Luu (Inactive)
                Reviewer:
                Chris Barber
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code