Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-14629

CLI: iOS Symbols wrongly imported from metadata.json

    Details

      Description

      Issue

      When you want a module to export symbols for the app build you create a metadata.json and put something like this in it

      {"exports": ["Ti.Media"]}

      Now in CLI at that line, symbols are wrongly imported because the "Ti." should be first removed.

      Consequently we get the wrong #define and we get link errors. The "addSymbol" method should handle this with something like this:

      • symbol = symbol.replace(/^(Ti|Titanium)./, "");
      PR

      Actually the find symbols process was very dirty for iOS.
      Decided to clean it: https://github.com/Akylas/titanium_mobile/commit/79efdba3d89cd536c7e84d037a1126030d92dff9

      I will create a PR if asked to do so

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              farfromrefuge Martin Guillon (Inactive)
              Reviewer:
              Sabil Rahim
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-17047
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code