Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13746

Android: Controls does not show on start of Ti.Media.VideoPlayer when playing MP3.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Invalid
    • Affects Version/s: Release 2.1.4, Release 3.0.2, Release 3.1.0
    • Fix Version/s: None
    • Component/s: Android

      Description

      The default behavior of TI.Media.VideoPlayer on Android shows no control on start. Users have to click the video to bring up the control.
      Here is a test case:

      var vidWin = Titanium.UI.createWindow({
          title : 'Video View Demo',
          backgroundColor : '#fff'
      });
       
      var videoPlayer = Titanium.Media.createVideoPlayer({
          top : 2,
          autoplay : true,
          backgroundColor : 'blue',
          height : 300,
          width : 300,
          mediaControlStyle : Titanium.Media.VIDEO_CONTROL_DEFAULT,
          scalingMode : Titanium.Media.VIDEO_SCALING_ASPECT_FIT
      });
       
      videoPlayer.url = 'clipcanvas_14348_H264_640x360.mp3';
      vidWin.add(videoPlayer);
      vidWin.open();
      

      Note: This behavior is noticed only when playing MP3 files.

        Attachments

          Activity

            People

            • Assignee:
              bijuexalture Biju pm
              Reporter:
              mpathak Meenakshi Pathak
              Reviewer:
              Vishal Duggal (Inactive)
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-16396
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration