Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13733

Liveview: Hook evals commands for "--liveview" and this causes "ti build -h" to not show liveview flag info

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.1.1
    • Fix Version/s: Release 3.1.2
    • Component/s: LiveView
    • Environment:

      Mac OS 10.8.3
      Xcode 4.6
      CLI: 3.1.0
      Alloy: 1.1.1
      Appcelerator Studio, build: 3.1.1.201304302240
      Titanium SDK version 3.1.1.v20130430164508

      Description

      Description:

      Liveview does not appear in "ti build -h", this seems to be caused by the line:

      if (process.argv.indexOf('--liveview') === -1) { return; }
      

      In the file: /Applications/Appcelerator Studio/plugins/com.appcelerator.titanium.liveview.core_1.0.0.1367297126/node_modules/liveview/hook/lvhook.js

      Steps to reproduce:

      1) Use terminal command "ti build -h"

      Result:

      Liveview is not represented

      Expected Result:

      Details of "--liveview" flag appear

        Attachments

          Activity

            People

            • Assignee:
              csullivan Christian Sullivan
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-16385
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration