Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13602

Android: nine-patch image is not displayed properly

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: Android
    • Labels:
    • Environment:

      Description

      9-patch image working on SDK 3.0.2.GA is not working on 3.1.0.GA.

      I can't find any problem with the image file.

      The code I used:

      app.js

      	var win = Ti.UI.createWindow({
      	    backgroundColor: 'white',
      	    exitOnClose: true,
      	    fullscreen: false,
      	    title: 'Click button to test'
      	});
      	 
      	var button = Ti.UI.createButton({
      	    backgroundImage: '/images/bt_start.png',
      	    backgroundSelectedImage:'/images/bt_start_sel.png',
      	    title: 'Click me!',
      	    top: 10,
      	    width: 300,
      	    height: 200
      	});
      	button.addEventListener('click',function(e){
      	    Ti.API.info("You clicked the button");
      	});
      	win.add(button);
      	win.open();
      

      'bt_start.9.png' is attached.

      Running that will show a result like 'scr.jpg'

      When I changed the SDK to 3.0.2, it worked again.

      Thank you.

        Attachments

        1. 05_21_13_max.png
          05_21_13_max.png
          29 kB
        2. 05_21_13.png
          05_21_13.png
          31 kB
        3. bt_start.9.png
          bt_start.9.png
          2 kB
        4. fixed.png
          fixed.png
          27 kB
        5. scr.jpg
          scr.jpg
          154 kB

          Issue Links

            Activity

              People

              • Assignee:
                pwang Ping Wang
                Reporter:
                adreamer21 Sungil Kim
                Reviewer:
                Allen Yeung
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-16274
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration