Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13545

Android: ImageView: Remote image with "@" character doesn't display

    Details

    • Story Points:
      5
    • Sprint:
      2015 Sprint 04 SDK

      Description

      Problem description
      If you set an image with a "@" in the path, the image won't be loaded. This is because getCleanUri thinking it's a domain address. Therefore the test on the hash will return false. So the image is downloaded but not drawn.

      Repro notes
      Paste the @2x URL in the browser to verify the URL is valid.
      Uncomment cd-mini-graphic image to verify it working for standard images.
      Only the URL with @2x doesn't work.
      Works on iOS, not on Android.

      Test case

      var win = Ti.UI.createWindow({
      	backgroundColor : 'white'
      });
       
      var image = Ti.UI.createImageView({
      	bottom : 0,
      	width : 200,
      	height : 200,
      	backgroundColor : 'red',
      	image : 'http://dl.dropboxusercontent.com/u/255893/appcelerator@2x.png'
      	//image : 'http://www.appcelerator.com.s3.amazonaws.com/web/home/platform/cd-mini-graphic.png'
      });
       
      win.add(image);
      win.open();
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                hpham Hieu Pham
                Reporter:
                farfromrefuge Martin Guillon (Inactive)
                Reviewer:
                Pedro Enrique (Inactive)
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-16235
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration