Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13483

CLI: bad error message when building for Android with both device and emulator open

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Duplicate
    • Affects Version/s: Release 3.0.2, Release 3.1.0
    • Fix Version/s: None
    • Component/s: Android, Tooling
    • Environment:

      CLI versions 3.0.24 and 3.1.0-cr
      TiSDK 3.1.0.v20130405170202
      Appcelerator Studio 3.1.0.201304052347
      Titanium Studio 3.1.0.201304051530
      Android OS

      Description

      Problem description

      When building for Android Device with also the Android simulator open, a misleading bad error message is displayed.

      Steps to reproduce

      1. Connect an Android device, create a default new project and build for Android simulator
      2. Build for Android real device (both from Studio and CLI)

      Result:
      1. App build and automatically run as expected on the simulator
      2. App build and is actually correctly installed on the real device. However, the App it's not starting up automatically on device and a misleading bad error message is displayed on the console log.

      [DEBUG] Waiting for device to be ready ...
      [TRACE] adb devices returned 2 devices/emulators
      [DEBUG] Device connected... (waited 0 seconds)
      [DEBUG] waited 0.019870 seconds on emulator to get ready
      [INFO] Installing application on device
      [DEBUG] /Users/fcasali/tools/android-sdk-mac_x86/platform-tools/adb -d install -r /Users/fcasali/Documents/Titanium_Studio_Workspace2/testProject/build/android/bin/app.apk
      [INFO] Application installed. Launch from drawer on Home Screen
      [INFO]  Launching appliation on device.
      error: more than one device and emulator
      [ERROR] Project failed to build after 29s 590ms
      

      Behavior reproducible with latest Appcelerator and Titanium Studio version.
      It was not reproducible building from Studio 3.0-GA version - however it was reproducible building from console with CLI version 3.0.24-GA.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                fcasali Federico Casali
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-16182
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code