Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13178

CLI: Alpha package will not install with node v0.8.17 and npm v1.2.0 configuration

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Won't Fix
    • Affects Version/s: Release 3.1.0
    • Component/s: CLI
    • Labels:
    • Environment:

      Mac OS 10.8.3
      Node v0.8.17
      npm v1.2.0

      Description

      Error

      When attempting to install the npm package for the CLI "sudo npm install -g titanium@3.0.25-alpha", I would get two lines, then the install seemed to hang:

      npm http GET https://registry.npmjs.org/titanium/3.0.25-alpha
      npm http 304 https://registry.npmjs.org/titanium/3.0.25-alpha
      

      npm cache clean gave slightly better results:

      npm http GET https://registry.npmjs.org/titanium/3.0.25-alpha
      npm http 200 https://registry.npmjs.org/titanium/3.0.25-alpha
      npm http GET https://registry.npmjs.org/titanium/-/titanium-3.0.25-alpha.tgz
      npm http 200 https://registry.npmjs.org/titanium/-/titanium-3.0.25-alpha.tgz
      

      But the CLI was not installed. We found this:
      https://github.com/isaacs/npm/issues/3058

      Workaround:

      Update npm version with: sudo npm install npm -g
      Then retry install.

      Steps to reproduce:

      1) Ensure you have the indicated versions of node and npm
      2) try to install alpha version with "sudo npm install -g titanium@3.0.25-alpha"

      Result:

      The install fails with 2-4 lines then hang

      Expected:

      Install succeeds

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                csullivan Christian Sullivan
                Reporter:
                emerriman Eric Merriman
                Reviewer:
                Bryan Hughes
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-15987
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration