Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-13103

CLI: Intermittent iOS Simulator failure

    Details

      Description

      While testing TIMOB-12722 I ran into issue where Application has exited from iOS simulator with the following error:
      [INFO] Finished building the application in 25s 824ms
      [INFO] Running application in iOS Simulator
      [INFO] Launching application in iOS Simulator
      [INFO] Focusing the iOS Simulator
      [INFO] Application has exited from iOS Simulator
      [INFO] Project built successfully in 29s 859ms

      [ERROR] Failed to focus the iPhone Simulator window
      [ERROR] /Users/oromero/Library/Application Support/Titanium/mobilesdk/osx/3.1.0.v20130316201654/iphone/iphone_sim_activate.scpt: execution error: iPhone Simulator got an error: Connection is invalid. (-609)

      Test steps:
      1. Create the default Alloy project project
      2. Run command ti build --platform iphone in command line

      Actual result:
      The error
      Expected result:
      App should launch successfully in iOS simulator

      Note: Running the same command second time works fine

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                oromero Olga Romero
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-15925
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration