Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-12745

CLI : CLI 'waits for the device' even though the build only flag is specified in the command for android

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: CLI
    • Labels:
    • Environment:

      Environment:
      CLI version :3.0.24-cr
      Win 8
      MAC OSX 10.8.2
      linux 12.04 LTS

      Description

      Description:
      1.Run the command in CLI :
      "ti build -p android -f --build-only -d 'proj-dir' "
      2.Check out the output on cli

      Actual result:
      1.The project builds but the CLI waits for the device
      We see something like this:

      [INFO]  Project built successfully in 6s 209ms
       
      [DEBUG] C:\Users\QEtester\Desktop\android-sdk-windows\platform-tools\adb.exe start-server
      - waiting for device -
      

      Expected Result:
      1.The CLI should only build the project but not wait for the device in build only senario

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                lokeshchdhry Lokesh Choudhary (Inactive)
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-15653
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration