Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-12650

iOS: "iOS Simulator failed to install the application"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Invalid
    • Affects Version/s: Release 3.0.2
    • Fix Version/s: None
    • Component/s: iOS, Tooling
    • Environment:

      OS: Lion 10.7.5
      XCode: 4.6
      Titanium Studio: 3.0.2.201302041757
      SDK Version:3.0.2.v20130207164659

      Description

      Works fine with Xcode 4.5.

      Steps To Reproduce:
      ======================
      1. Create a default project.
      2. Run project in iOS simulator

      Actual:
      ========
      [ERROR] : An error occurred running the iOS Simulator
      [ERROR] : [DEBUG] Session could not be started: Error Domain=DTiPhoneSimulatorErrorDomain Code=1 "iOS Simulator failed to install the application." UserInfo=0x101a0f2a0

      {NSLocalizedDescription=iOS Simulator failed to install the application., DTiPhoneSimulatorUnderlyingErrorCodeKey=-1}

      [ERROR] :
      [ERROR] : Project failed to build after 21s 304ms

      Expected:
      ==========
      Project must launch successfully in simulator.

      Workaround:
      ============
      Deleting files from /Users/pragya.rastogi/Library/Application Support/iPhone Simulator/6.1/Applications resolves the issue temporarily.
      'iOS Simulator > Reset Content and Settings...' works as well.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                prastogi Pragya Rastogi
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-15592
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration