Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-12576

iOS: Background mode "audio" does not work with SDK 3.0.0.GA

    Details

      Description

      Problem description
      iOS Background Mode "audio" is not correctly converted to the Info.plist file with SDK 3.0.0.GA.

      tiapp.xml

      <iphone>
          <backgroundModes>
              <mode>audio</mode>
          </backgroundModes>
      </iphone>
      

      Workaround
      1. Set for Ti.SDK 3.0.0
      2. Compile the app to go on the device
      3. DO NOT TRANSFER it
      4. In the folder

      {appfolder}/build/iphone find the file info.plist
      5. Copy this file into {appfolder}

      /
      6. Edit this file; and add the key above (exactly as it is shown)
      7. Compile again for the device
      8. Put it on the device now
      9. Test it - should work.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dsefton Daniel Sefton
                Reporter:
                mdescher Michael Descher
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-15537
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code