Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-12422

iOS build using deploy-type parameter does not exclude/include modules

    Details

      Description

      The deploy-type parameter is enabled for iOS, but it doesn't perform as expected.

      Steps:
      1. Create titanium project
      2. Add ti.cloud module
      3. Update the app.js with the following code:

      var module = require('ti.cloud');

      4. Set deploy-type in the tiapp.xml for ti.cloud to be "development"
      5. Perform a build using deploy-type="test"

      /usr/local/bin/titanium --no-colors --no-prompt build --platform ipad --sdk 3.1.0.v20121220122601 --log-level info --target simulator --ios-version 5.1 --device-family ipad --deploy-type development --debug-host 10.0.14.194:62565

      Expected results:
      App launch should fail because the ti.cloud module was not loaded since it wasn't present

      Actual results:
      ti.cloud module is present, app loads

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              nle Nam Le (Inactive)
              Reviewer:
              Bryan Hughes
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-15427
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration