Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-12312

CLI: Setup wizard doesn't save the default sdk, on the Next run of Setup wizard, configuration changes automatically

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 3.0.0, Release 3.1.0
    • Component/s: CLI
    • Labels:
    • Environment:

      SDK version: 3.0.1.v20130111165328 , 3.1.0.v20130111163212, 3.0.0.GA
      CLI version : 3.0.22
      OS : MAC OSX 10.7.5
      XCode : 4.5.1

      Description

      CLI: Setup wizard doesn't save the default sdk, on the Next run of Setup wizard, configuration changes automatically.

      Steps to reproduce:
      1. Run "Titanium setup"
      2. supply the sdk version which you want to be default in the prompt.
      3. finish the Setup wizard.
      4. Run "Titanium setup" again
      5. Run titanium config to verify the sdk version.
      Actual result:

      Default sdk version should be the one saved before but it changes to the last sdk mentioned in installed directory i.e. "Users/paras.mishra/Library/Application Support/Titanium/mobilesdk/osx"

      Expected Result:

      Default SDK version should point to the changed SDK version in setup wizard.

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              pmishra Paras Mishra
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-15334
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration