Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-11993

Android: Simple Animation Applied to a View doesn't play nice

    Details

      Description

      Problem

      It looks like our "Simple Animation Applied to a View" doesn't play nice in Android.

      Tested on

      Razr 2.3.5
      iOS 6 simulator

      Docs

      http://docs.appcelerator.com/titanium/2.1/#!/api/Titanium.UI.Animation

      Simple sample

      var win = Titanium.UI.createWindow({
      	backgroundColor : '#FFF',
      });
       
      var view = Titanium.UI.createView({
      	backgroundColor : 'red'
      });
       
      var animation = Titanium.UI.createAnimation();
      animation.backgroundColor = 'black';
      animation.duration = 3000;
       
      var animationHandler = function() {
      	animation.removeEventListener('complete', animationHandler);
      	animation.backgroundColor = 'orange';
      	view.animate(animation);
      };
       
      animation.addEventListener('complete', animationHandler);
      view.animate(animation);
       
      win.add(view);
      win.open(); 
      

        Attachments

          Activity

            People

            • Assignee:
              sunila Sunila
              Reporter:
              egomez Eduardo Gomez (Inactive)
              Reviewer:
              Allen Yeung
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-15128
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration