Titanium Mobile
  1. Titanium Mobile
  2. TIMOB-11678

CLI: iOS: iPad Simulator launches as iPhone Simulator

    Details

      Description

      This is regression issue. With 2.1.2 Studio and latest SDK, iPAD Simulator launches.
      Steps To Reproduce:
      1. Install Studio 3.0 latest version with latest SDK and plugins.
      2. Create a default app.
      3. Run same app using iPAD Simulator

      Actual: App launches in iPhone Simulator.
      Expected: App must launch in iPAD Simulator.

        Issue Links

          Activity

          Eric Merriman added a comment -

          I understand now. One thing to note:
          -F is device family. This is used for determining what iOS device the app will run on:
          -F ipad - iPad only app
          -F iPhone - iPhone/iPod, will run on iPad but in iPhone idiom
          -F universal - works on all devices, on iPad should be in iPad idiom

          Ingo Muschenetz added a comment -

          Chris indicates this may be fixed as a result of addressing TIMOB-5992.

          Sabil Rahim added a comment -

          Should have been fixed as a result of TIMOB-5992 - PR 3945

          Olga Romero added a comment - - edited

          Looks like it is fixed as a result of TIMOB-5992.

          Tested with:
          Titanium Studio, build: 3.1.0.201303182358
          Titanium SDK, build: 3.1.0.v20130320123256
          CLI 3.0.25
          XCode 4.6
          iOS Mountain Lion 10.8.2

          and confirmed that iPad Simulator launches properly.

          Pragya Rastogi added a comment -

          Verified as fixed using:
          OSX: 10.9.3
          Xcode: 5.1.1
          Appcelerator Studio: 3.3.0.201406171619
          SDK -3.3.0.v20140617161713
          acs-1.0.14
          alloy-1.4.0-rc
          npm-1.3.2
          titanium-3.3.0-rc
          titanium-code-processor-1.1.1


            People

            • Assignee:
              Sabil Rahim
              Reporter:
              Pragya Rastogi
            • Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Poker Sessions

                  This issue is currently not assigned to any Poker Session.