Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-11230

iOS: Device Debugger: no error message if connection fails

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Invalid
    • Affects Version/s: Release 3.0.0
    • Component/s: iOS
    • Environment:

      Titanium SDK: 3.0.0.v20121002103353
      Titanium Studio: 3.0.0.201210012124
      OS: Mountain Lion 10.8.2
      Xcode: 4.5
      Device: iPad2 4.3.5

      Description

      During iOS device debugging, if the app launches and the session fails to connect to Studio, there is no immediate error message, only "Waiting for debugger to connect..." with a possible time-out.

      Steps to Reproduce:

      1. Debug on iOS Device.
      2. Install app to device.
      3. Cancel debug process from Studio.
      4. Launch app from device (knowing it should fail).

      Actual Result:

      "Waiting for debugger to connect..." and possible time-out.

      Expected Result:

      Immediate error (within 0 - 10 seconds, or whatever appropriate) indicating problem.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mstepanov Max Stepanov
                Reporter:
                dhyde Dustin Hyde
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-14509
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration