Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-10594

Android: HTML5 <video> tag is not working as expected inside a webview

    Details

      Description

      Problem description

      When opening a page with a <video> tag, the video is not properly shown in a webview. The same url works in the native browser of the device, as well as on iOS.

      Steps to reproduce

      1. Create the following app and open it:

      ~~~
      (function()

      { var window = Titanium.UI.createWindow(); var webView = Titanium.UI.createWebView(); webView.url = 'http://camendesign.com/code/video_for_everybody/test.html'; window.add(webView); window.open(); }

      )();
      ~~~

      Additional note

      The same URL works in Chrome and in the native browser

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ingo Ingo Muschenetz
                Reporter:
                dcassenti Davide Cassenti
              • Watchers:
                0 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-14011
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration