Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-10150

iOS: NavGroup - Events are not firing and windows are not opening properly in NavGroup

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Invalid
    • Affects Version/s: Release 2.1.1
    • Fix Version/s: None
    • Component/s: iOS
    • Environment:

      Tested on:
      Titanium Studio, build: 2.1.1.201207161421
      Titanium SDK: 2.1.1.v20120723131610
      iPhone4 4.3.5

      Description

      Description:
      While conducting the test using the sample code from TIMOB-8027, I noticed that windows are not opening properly in NavGroup and events are not firing.

      This is a regression, occurs in 2.1.1 Does not occur in 2.1.0.GA or 2.0.1.GA2

      Steps to reproduce:
      1. Run the test code from TIMOB-8027
      2. Note text of alert

      Actual result:
      Single window appears with no navBar, small sliver of win2 appears at the bottom of the screen, only a single alert shown.

      Expected result:
      A red window with NavGroup opens sn two alerts are shown (win1 and win2). It is possible to navigate back to the red window (win1) with navBar, which then presents additional alert for win1.

        Attachments

          Activity

            People

            • Assignee:
              ngupta Neeraj Gupta
              Reporter:
              oromero Olga Romero
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-5508
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code