Uploaded image for project: 'Documentation'
  1. Documentation
  2. TIDOC-2510

Ti.App.registerUserNotifications gives no response at all

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: No Fix
    • Component/s: Guides
    • Story Points:
      1
    • Sprint:
      Sprint 09 2016: 4/17 - 4/30, Sprint 38 - 2016: Mega Man

      Description

      This was working before, but I created a new app and I'm using 5.2.2 SDK and I can't for the life of me get it to work.

      I'm copying the exact example from Titanium's docs and no callback is firing.
      One thing to note is that I'm not using Appcelerator cloud and I'm not using any plugin, the reason I'm saying that is that I saw someone posted a solution online but I haven't tried it yet, I'm pasting what he wrote below.

      Calling Ti.Network.registerForPushNotifications() has no response, whether success, error or callback, basically no response at all. Turned out that the build script can’t detect the method and add USE_TI_NETWORKREGISTERFORPUSHNOTIFICATIONS to defines.h during app compilation.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bimmel-defective (deactived) Brian Immel (Inactive)
                Reporter:
                khalilsarabey Khalil Sarabey
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration