Uploaded image for project: 'Documentation'
  1. Documentation
  2. TIDOC-2470

Update module guides to use CLI instead of build.py

    Details

    • Type: Story
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.2.1
    • Fix Version/s: Release 6.0.0, Release 6.1.0
    • Component/s: Guides
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      Sprint 06 2016: 3/6 - 3/19, Sprint 37 - 2016: Data, Sprint 38 - 2016: Mega Man, Sprint 41 - 2016: HAL 9000, Sprint 42 - 2016: ED-209

      Description

      TIMOB-20489 requires module developers to use the CLI to build instead of the (for some time already) deprecated build.py from Ti 5.2.1 on. The guides need to updated for this.

      Some questions I'm sure Chris Barber can answer:

      • When will build.py be removed from newly generated projects?
      • Should we say that build.py is deprecated or remove?
      • How exactly should ti build be used to build iOS (and Android?) modules?
      • What if you use the Unified CLI? Is is appc run or appc ti build?
      • What would be the exact steps to upgrade a module from using build.py to ti build?
      • What additional steps need to be taken for modules that relied on the platform/iphone bug fixed by TIMOB-19694 which caused TIMOB-20489?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                bimmel-defective (deactived) Brian Immel (Inactive)
                Reporter:
                fokkezb Fokke Zandbergen
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code