Uploaded image for project: 'Appcelerator Modules'
  1. Appcelerator Modules
  2. MOD-2366

Android: appcelerator.encrypteddatabase module fails with SDK 6.2.0+

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: appcelerator.encrypteddatabase 2.0.2
    • Fix Version/s: None
    • Component/s: Encrypted SQLite DB
    • Labels:
      None
    • Environment:

      Node Version: 6.0.0
      NPM Version: 3.10.10
      Mac OS: 10.11.6
      Appc CLI: 6.2.4
      Appc CLI NPM: 4.2.9
      Appcelerator Studio vers 4.10.0
      Titanium SDK version: 6.2.2
      Encrypted Database Module 2.0.2

    • Story Points:
      5
    • Sprint:
      2017 Sprint 20 SDK

      Description

      When running Encrypted database module with sdk 6.2.x the module errors out with the following error:

      [ERROR] : TiExceptionHandler: (main) [0,291] - Message: Uncaught dlopen failed: library "libutils.so" not found

      full log attached below.

      steps to reproduce

      Create a new project using Encrypted Database Module 2.0.2
      Build with SDK 6.2.+

      Additional information

      Works fine with anything before SDK 6.2.0

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gmathews Gary Mathews
                Reporter:
                vvazquezmontero Victor Vazquez Montero
              • Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Integration