Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-976

"appc use" seems to broken with core 5.2.1-18 in preprod

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.2.1
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
    • Environment:
    • Story Points:
      3
    • Sprint:
      2016 Sprint 07 Tooling

      Description

      Steps to reproduce:

      1. Install core 5.2.1-18 in preprod & run "appc use"

      Actual Results:

      1. Error is thrown:

      /usr/local/lib/node_modules/appcelerator/lib/use.js:115
          var latest = listResult[0].version;
                                    ^
       
      TypeError: Cannot read property 'version' of undefined
          at findLatest (/usr/local/lib/node_modules/appcelerator/lib/use.js:115:28)
          at /usr/local/lib/node_modules/appcelerator/lib/use.js:63:18
          at IncomingMessage.<anonymous> (/usr/local/lib/node_modules/appcelerator/lib/util.js:580:5)
          at emitNone (events.js:72:20)
          at IncomingMessage.emit (events.js:166:7)
          at endReadableNT (_stream_readable.js:905:12)
          at doNTCallback2 (node.js:441:9)
          at process._tickCallback (node.js:355:17)
      Lokeshs-MacBook-Pro:Desktop lokeshchoudhary$ 
      

      2. It seems to be intermittent.

      Expected Results:

      1. "appc use" should list the available core versions.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fmiao Feon Sua Xin Miao
                Reporter:
                lchoudhary Lokesh Choudhary
                Reviewer:
                Chee Kiat Ng (Inactive)
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code