Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-943

Core 5.2.0 displays incorrect/confusing warning if NPM is still < 4.2.3

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 5.2.0
    • Fix Version/s: Release 5.2.1
    • Component/s: Core
    • Labels:
      None
    • Environment:

      $ appc -v -o json

      {"NPM":"4.2.2","CLI":"5.2.0"}
    • Severity:
      Major
    • Story Points:
      2
    • Sprint:
      2016 Sprint 04 Tooling

      Description

      We hard-coded a minimum version for the NPM part of the CLI, but haven't updated it to use the GA so it's still asking for 4.2.3-2.

      We need CLI-757 and CLI-696 resolved to prevent this in the future.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fokkezb Fokke Zandbergen
                Reporter:
                fokkezb Fokke Zandbergen
                Reviewer:
                Feon Sua Xin Miao
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code