Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-922

-d flag error on appc ti sdk install

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 5.2.0
    • Fix Version/s: Release 5.2.0
    • Component/s: None
    • Environment:

      Appc CLI 5.2.0-220
      Node 0.12.7

    • Severity:
      Minor
    • Story Points:
      3
    • Sprint:
      2016 Sprint 03 Tooling

      Description

      When trying to download an SDK and set it to default, in one command, I get the below error:

      appc ti sdk install -b 5_2_X -d
       
        error: option `-d, --dashboard <dashboard>' argument missing
      

      Steps to reproduce issue
      1. Run appc ti sdk install -b 5_2_X -d

      Expected results
      The SDK downloads and is set to the default

      Actual results
      The SDK is not downloaded and the above error is shown

      Notes
      if the '-d' flag is immediately after the word 'install' the command succeeds (appc ti sdk install -d -b 5_2_X)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fmiao Feon Sua Xin Miao
                Reporter:
                ewieber Eric Wieber
                Reviewer:
                Dawson Toth
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code