Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-879

Get error when customer do "appc setup"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Needs more info
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Titanium
    • Labels:
      None
    • Environment:

      CLI 5.0.4
      SDK 5.0.2.GA
      NodeJS 5.0

      Description

      One of customer keep following error when he do "DEBUG=* appc setup -l trace"

      /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/iphone/cli/lib/info.js:40 
       
      results.devices.unshift({ 
       
      ^ 
       
      TypeError: Cannot read property 'devices' of undefined 
       
      at Section.<anonymous> (/Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/iphone/cli/lib/info.js:40:10 ) 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/ioslib/index.js:115:12 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:697:13 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:52:16 
       
      at done (/Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:243:17 ) 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:44:16 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:694:17 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/async/lib/async.js:173:37 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/ioslib/index.js:85:6 
       
      at /Users/dangoldberg/Library/Application Support/Titanium/mobilesdk/osx/5.0.2.GA/node_modules/ioslib/lib/device.js:51:12 
       
      ERROR | Error: titanium exited with 1 exit code 
      

      Attached the full log file as well

      Not sure why this happen, only different is they use node 5.0, does it related?
      But their environment require node 5.0 for those software, so is there something we can do.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                pinnamuri Praveen Innamuri (Inactive)
                Reporter:
                sliang Shuo Liang
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code