Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-747

Node processes are getting orphaned in certain cases

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 5.0.0
    • Component/s: Core
    • Labels:
      None
    • Story Points:
      1
    • Sprint:
      2015 Sprint 15 Tooling

      Description

      If you kill a top level process like appc run (the first process), the sub processes that are spawned are not killed and become orphaned.

      I am easily able to reproduce this with a test case. Sometimes you can reproduce it with killing the process with CTRL+C before fully started running.

      You can probably also easily reproduce this by starting an arrow server successfully then just sending a kill SIGINT to the main appc process from ps.

        Attachments

          Activity

            People

            • Assignee:
              jhaynie Jeff Haynie (Inactive)
              Reporter:
              jhaynie Jeff Haynie (Inactive)
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 15 minutes
                15m

                  Git Source Code