Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-578

When no SDKs are installed, running appc ti sdk -o json returns unparseable error text

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: Release 4.0.0
    • Component/s: Titanium
    • Labels:
      None
    • Severity:
      Major
    • Sprint:
      2015 Sprint 08 Tooling

      Description

      I wiped my .appcelerator folder and then did a appc use latest and started Studio. I had no Titanium SDKs installed because I never ran appc setup. Studio attempts to get the SDK listing with appc ti sdk -o json and the output is not all JSON, it gives:

      [WARN] :   Titanium undefined has been deprecated and will not work with future releases.
      [WARN] :   Please use Titanium 3.2 or newer.
      {
      	"activeSDK": "4.0.0.v20150417113416",
      	"defaultInstallLocation": "C:\\ProgramData\\Titanium",
      	"installLocations": [
      		"C:\\ProgramData\\Titanium",
      		"C:\\Users\\Christopher\\AppData\\Roaming\\Titanium",
      		"C:\\ProgramData\\Application Data\\Titanium"
      	],
      	"installed": {}
      }
      

      As a result Studio fails to parse the response. The error text should be folded into the json response.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gmathews Gary Mathews
                Reporter:
                cwilliams Christopher Williams
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code